Artboard 99 copy 8

FREE SHIPPING on all orders over $50

CONTACT US

Call us

Phone us on
1300 443 279

Email us

Email us directly on remotesupport@connecthearing.com.au

Book a consultation

Book an appointment with our telehealth team.

Clinic Locations

Find your local Connect Hearing clinic now

Useful Downloads

Teamviewer

 

We use TeamViewer to help us remotely and securely connect to your device (computer or tablet) during fine-tuning screen share sessions.

MyPhonak

Your Phonak Marvel hearing aids pair with MyPhonak so you can adjust your settings and connect directly to your clinician.

Android

MyPhonak for Android requires Android OS version 6.0 (a.k.a. “Marshmallow”) or newer, as well as Bluetooth version 4.2 or newer.

iPhone and iPad

MyPhonak for iPhone and iPad supports iOS 10.2 or newer, as well as Bluetooth version 4.2 or newer.

IHearYou®

IHearYou® software is free on all supported platforms. The current version of IHearYou® is compatible with all Blamey Saunders hearing aid models.

The latest version of IHearYou requires the Incus programmer. The AHPro3 (black, square box) is not supported.

 

Windows

The latest version of IHearYou requires Windows Vista, 7, 8, 8.1, or 10.

Android

IHearYou for Android requires a device with Bluetooth functionality. The minimum Android OS version requirement is 4.0.3, but we recommend Android 4.4 (a.k.a. “KitKat”) or newer.

iPhone and iPad

IHearYou for iPhone and iPad supports iOS 10 or newer.

Scroll to Top

This website or application uses cookies. In order to find out more about our use of cookies, please consult our Privacy Policy.